Search found 328 matches

by s14BEAST808
Fri Feb 15, 2013 2:59 pm
Forum: KA-T Chat
Topic: ABS Diff??????????
Replies: 17
Views: 8026

sorry to bump an old thread, I'm having the exact same issue as well. I have a s14 non abs/open dif ordered the same shaft (STEEL tho) and it was too long. I made it fit by dropping the cross member and wedgeing it up in there, but i get this god awful noise when coming out of first LOL My car was a...
by s14BEAST808
Sun Sep 04, 2011 2:08 pm
Forum: ECU Tuning
Topic: S14 Auto ECU
Replies: 5
Views: 1615

jezz cut the guy some slack
by s14BEAST808
Wed Aug 17, 2011 10:48 am
Forum: KA-T Tech. Basic
Topic: Hesitation Issues
Replies: 21
Views: 2405

replace the pumpppp
by s14BEAST808
Mon Aug 15, 2011 7:46 pm
Forum: KA-T Tech. Basic
Topic: How To Install Your Distributor Easy and Fast in s13/s14
Replies: 6
Views: 12961

LOL i believe you. Which two tho? I know you can see the one thats right there, but are you talking about the intake as well?
by s14BEAST808
Mon Aug 15, 2011 7:41 pm
Forum: KA-T Tech. Basic
Topic: How To Install Your Distributor Easy and Fast in s13/s14
Replies: 6
Views: 12961

Well are you sure that it was always come to tdc EVERYTIME?? Everytime there facing away from each other its on #1 compression stroke? Cause **** i thought the same, and never could get it, i always just stuck with the popping of the plug wire
by s14BEAST808
Mon Aug 15, 2011 7:33 pm
Forum: KA-T Tech. Basic
Topic: Hesitation Issues
Replies: 21
Views: 2405

had the same issues, and replaced every thing you did. Turned out it was just the damn fuel pump. let me know if that helps. PLEASE let me know if it helps. Also it wouldnt hurt to stab another dizzy in there. When the mafs unplugged and you WOT it, does it stumble all the way to 2<500? Or does it r...
by s14BEAST808
Sun Aug 07, 2011 3:00 pm
Forum: KA-T Tech. Basic
Topic: How To Install Your Distributor Easy and Fast in s13/s14
Replies: 6
Views: 12961

How To Install Your Distributor Easy and Fast in s13/s14

1. Find Number 1 Compression Stroke Make Sure your dizzy is removed, remove number one spark plug, replace your number one spark plug WIRE back in the hole. Now get in ur car and turn the key on and off very fast until the plug shoots UP. This will mean you are on your compression stroke. 2. Findin...
by s14BEAST808
Sun Jul 10, 2011 2:04 pm
Forum: KA-T Tech. Basic
Topic: Misfire by leaky injector?
Replies: 5
Views: 1208

did you replace them yet?
by s14BEAST808
Wed Jun 29, 2011 11:29 am
Forum: KA-T Tech. Basic
Topic: BAD MAF, OR is this normal?
Replies: 14
Views: 1295

92 Oct i believe
by s14BEAST808
Wed Jun 29, 2011 11:28 am
Forum: KA-T Tech. Basic
Topic: BAD MAF, OR is this normal?
Replies: 14
Views: 1295

V-Power from Shell. (Premium) As much as possible.
by s14BEAST808
Wed Jun 29, 2011 11:28 am
Forum: KA-T Tech. Basic
Topic: FINALLY found problem, need advice
Replies: 60
Views: 8973

the whole time it was your IACV???
by s14BEAST808
Tue Jun 28, 2011 7:15 pm
Forum: KA-T Tech. Basic
Topic: BAD MAF, OR is this normal?
Replies: 14
Views: 1295

So i found someone locally to swap mafs. And of course when i meet up with him, my car acts normal and dosesnt hesitate at all......... so irrataing... So i swapped mafs and it just seemed fine, like i didnt do anything at all. It seems intermentint.... SO my next step is to pick up some injectors, ...
by s14BEAST808
Tue Jun 28, 2011 2:32 am
Forum: KA-T Picture Threads
Topic: Mansalad S13
Replies: 65
Views: 11726

MORE pics of the new setup!!! and is this ka stock internals or fully built? most likely fully built LOL, and please post some videos inside and out! And did you keep your shift stick from your sr?
by s14BEAST808
Tue Jun 28, 2011 1:48 am
Forum: KA-T Picture Threads
Topic: Gold s14 ka-t,.....new dyno 333whp 327ftq @9psi
Replies: 156
Views: 43339

omg............ Unbelievable.... How much do you think you have put in to this car, and what the hell do you do for a living! Im ***** so jealous right now. I kinda hate you, but then at the same time look up too you. hahahhahaha. Your car is BEAST dude. You making that kinda horse on stock internal...
by s14BEAST808
Mon Jun 27, 2011 11:28 pm
Forum: KA-T Tech. Basic
Topic: Different gas has HUGE effects
Replies: 10
Views: 1207

well im buying a set of used injectors from this site tomorrow, then off to detchwerks they go.
by s14BEAST808
Mon Jun 27, 2011 11:19 pm
Forum: KA-T Tech. Basic
Topic: BAD MAF, OR is this normal?
Replies: 14
Views: 1295

UGGGG come on guys. People on this island suck dicckk. Nobody will meet up with me just so I can test to see if my maf works or not
by s14BEAST808
Mon Jun 27, 2011 8:45 pm
Forum: KA-T Tech. Basic
Topic: Different gas has HUGE effects
Replies: 10
Views: 1207

well could it be my injectors?
by s14BEAST808
Mon Jun 27, 2011 7:38 pm
Forum: KA-T Tech. Basic
Topic: BAD MAF, OR is this normal?
Replies: 14
Views: 1295

Everything is completly stock except the gutted cat and 2.5 inch megan catback exhaust with test pipe
by s14BEAST808
Mon Jun 27, 2011 7:37 pm
Forum: KA-T Tech. Basic
Topic: BAD MAF, OR is this normal?
Replies: 14
Views: 1295

yeah i bought genuine maf cleaner.... didnt really notice a change
by s14BEAST808
Mon Jun 27, 2011 5:19 pm
Forum: KA-T Tech. Basic
Topic: BAD MAF, OR is this normal?
Replies: 14
Views: 1295

When the maf is plugged in, and if i open the throttle all the way super fast, it hesitates for a good second then climbs up finally, when the mafs unplugged it revs up SUPER fast to 2500 rpms.
by s14BEAST808
Mon Jun 27, 2011 5:17 pm
Forum: KA-T Tech. Basic
Topic: car not starting after walbro fuel pump install
Replies: 31
Views: 2980

Jmcc wrote:
ATL240 wrote:does anyone no how I can give the pump direct power without openinig the gas tank?
jump the relay.
I second this. Jump it and see if that helps it.
by s14BEAST808
Mon Jun 27, 2011 5:11 pm
Forum: KA-T Tech. Basic
Topic: BAD MAF, OR is this normal?
Replies: 14
Views: 1295

engine is n/a atm
by s14BEAST808
Mon Jun 27, 2011 4:59 pm
Forum: KA-T Tech. Basic
Topic: BAD MAF, OR is this normal?
Replies: 14
Views: 1295

BAD MAF, OR is this normal?

So im still having sputtering/misfiring issues time to time. Dizzy checks out good, sparks plugs are good, rotor is good, cap is good, plugs are new. This is my question about the maf Car runs about 900-1000 rpms with maf plugged in, a little shakey, and sometimes just suddenly dies. So while the en...
by s14BEAST808
Mon Jun 27, 2011 4:52 pm
Forum: KA-T Tech. Basic
Topic: ka-t wont stay running
Replies: 42
Views: 3342

sounds like a maf issue.... hows your throttle cable postion and your throttle position?
by s14BEAST808
Sun Jun 26, 2011 4:39 pm
Forum: KA-T Tech. Basic
Topic: car not starting after walbro fuel pump install
Replies: 31
Views: 2980

which hose are you talking about?
the return or send line?
by s14BEAST808
Sun Jun 26, 2011 4:38 pm
Forum: KA-T Tech. Basic
Topic: car not starting after walbro fuel pump install
Replies: 31
Views: 2980

err..... maybe you might just have a bad pump man... or somethings blocking... you should have constant pressure i believe
by s14BEAST808
Sun Jun 26, 2011 4:22 pm
Forum: KA-T Tech. Basic
Topic: Different gas has HUGE effects
Replies: 10
Views: 1207

Different gas has HUGE effects

I have noticed that certain gas's make my car run like **** IE. Chevron, Aloha. Tesero, Costco. When i have gone to 76 or shell my car purrs way more! haha, so could this be the injectors going ****??
by s14BEAST808
Sun Jun 26, 2011 4:09 pm
Forum: KA-T Tech. Basic
Topic: car not starting after walbro fuel pump install
Replies: 31
Views: 2980

Well you possible might have flooded it, but something else is wrong. Just wondering, what kind of FPR do you have? Is it just stock? And how did you wire the pump up? Did you follow the instructions correctly? Id say take your plugs out see if there covered in gas, and leave the plugs out for a day...
by s14BEAST808
Tue Jun 14, 2011 8:40 pm
Forum: KA-T Tech. Basic
Topic: Ka24de bogging question
Replies: 12
Views: 1418

you back yet
by s14BEAST808
Fri Jun 03, 2011 8:39 pm
Forum: KA-T Tech. Basic
Topic: FINALLY found problem, need advice
Replies: 60
Views: 8973

please reply with your answers!!! im haviong same issues