Is there anyway to fix a maf?

Dream about your 240's turbo power in this forum.
Post Reply
rojomojo
Driving Mom's Station Wagon
Posts: 22
Joined: Sun Mar 25, 2012 5:38 pm
Location: Canada
Contact:

Is there anyway to fix a maf?

Post by rojomojo » Sun Mar 03, 2013 3:07 pm

I was driving and my car just decided to die. So I pulled over and check fuel, plug blah blah. Then I checked my maf, and the car idles without the maf. The i put a multimeter to it and it reads 2.7 volts with the car off, and 3.7 volts with the car idling. Soo is there anyway to fix this?

I cleaned it with maf cleaner.

Regards

Rojo

User avatar
airman
KA-T.org OWNER
Posts: 2137
Joined: Tue Jun 16, 2009 12:51 pm
Location: Anderson, SC

Post by airman » Sun Mar 03, 2013 8:52 pm

Likely it has croaked - there is circuitry inside of it and it's likely that the board has gone bad. Not sure how to repair that.
R.I.P. 1990 Red Hatch - DOHC 5 speed // CP 9:1 - Eagle Rods - Clevite - ARP // Holset HX35 - 20psi daily - MSPNP2
8-bit wrote:You could spend your life building a ladder to the moon, or work for 5 years to pay for a trip.

User avatar
R34SR
Belongs To The TOP CONTRIBUTING MEMBERS!
Posts: 1901
Joined: Thu Sep 25, 2008 6:09 pm
Location: Florida

Post by R34SR » Tue Mar 05, 2013 11:54 am

throw it away, go map.
MEGASQUIRT 2 PNP
AEM IGN1A COILS
EAGLE-ARP-SUPERTECH 9:1 KA24DE
HOLSET HX35 .63 AR TURBO
Five-O 750cc INJECTORS
OBX T3 Manifold
ISIS FMIC
CC WHITEBUNNY 6 PUCK CLUTCH
Mazworx z32 tranny swap
CTS V CALIPERS
STANCE LX+ Coilovers
J30 LSD
AME FS01 WHEELS 18X9 +25
FEDERAL 595SS 245/40/18


TinyT wrote:for the love of god, post your setup, do you really think you can get an answer after saying HI ME CAR HAS TURBO NOW BUT I CANT BWAAA PSHH WITH IT WHATS WRONG

User avatar
airman
KA-T.org OWNER
Posts: 2137
Joined: Tue Jun 16, 2009 12:51 pm
Location: Anderson, SC

Post by airman » Tue Mar 05, 2013 1:29 pm

R34SR wrote:throw it away, go map.
^ Easier said than done - to the OP: going to a MAP would require a standalone ECU like Megasquirt, AEM, Haltech, etc which can be costly.

2.7v idle is a bad MAF. It will need to be replaced with a good one - sorry for the bad news!
R.I.P. 1990 Red Hatch - DOHC 5 speed // CP 9:1 - Eagle Rods - Clevite - ARP // Holset HX35 - 20psi daily - MSPNP2
8-bit wrote:You could spend your life building a ladder to the moon, or work for 5 years to pay for a trip.

User avatar
R34SR
Belongs To The TOP CONTRIBUTING MEMBERS!
Posts: 1901
Joined: Thu Sep 25, 2008 6:09 pm
Location: Florida

Post by R34SR » Tue Mar 05, 2013 5:07 pm

Yea I know, I god fedup with mafs, even reman ones would eventually die on me, just said eff it and got ms2 pnp, not sayin its feasable for everyone tho
MEGASQUIRT 2 PNP
AEM IGN1A COILS
EAGLE-ARP-SUPERTECH 9:1 KA24DE
HOLSET HX35 .63 AR TURBO
Five-O 750cc INJECTORS
OBX T3 Manifold
ISIS FMIC
CC WHITEBUNNY 6 PUCK CLUTCH
Mazworx z32 tranny swap
CTS V CALIPERS
STANCE LX+ Coilovers
J30 LSD
AME FS01 WHEELS 18X9 +25
FEDERAL 595SS 245/40/18


TinyT wrote:for the love of god, post your setup, do you really think you can get an answer after saying HI ME CAR HAS TURBO NOW BUT I CANT BWAAA PSHH WITH IT WHATS WRONG

User avatar
Walperstyle
Belongs To The TOP CONTRIBUTING MEMBERS!
Posts: 2516
Joined: Sat Jun 21, 2008 2:32 pm
Location: Red Deer

Post by Walperstyle » Tue Mar 05, 2013 9:27 pm

Well if you are going stand alone like motec run both lol
Image

User avatar
supakat
SuperMod
Posts: 8018
Joined: Sun Oct 08, 2006 12:13 pm
Location: FL

Post by supakat » Tue Mar 05, 2013 9:49 pm

You can run both with MS but it does not make sense quite honestly especially when I am planning on throwing 25psi into my motor shortly. The MAF would blow its hat off. But I did epoxy my n62 and it held with 20psi just fine.
12.96 @ 116.36 - 2.1 60ft - 11/2011
13.1 @ 114 - 2.3 60ft - 8/2012
KA24DE-T
Image
Build thread/Blog
YouTube Channel

dj_smooth
240sx Wannabe
Posts: 196
Joined: Sun Aug 10, 2008 12:35 pm
Location: Guam-- Moore, Oklahoma

Post by dj_smooth » Wed Mar 06, 2013 8:33 am

On my z32 maf, my circuit card fried. I followed the tracks on the board and soldered a jumper wire between the 2 pOints. The jumper is not shownin the pictures. Then use A consult to check your voltage. Also ohm out. Around 1volt should be idle.
Image
Image
Image

User avatar
shift_down
SuperMod
Posts: 1833
Joined: Mon Nov 28, 2011 11:00 am
Location: tulsa oklahoma

Post by shift_down » Wed Mar 06, 2013 8:42 am

Hey you know that circular mesh type filter in the maf housing? Is that a necessity if theres going to be a filter at the end of the maf? Im trying to cut the maf down a it to make some room, I was thinking of removing the mesh and trimming away at the plastic.
Come at me bro

Fast
Reliable
Cheap;
You can only pick two, so choose wisely!

My build thread: viewtopic.php?t=57539

niceguy
240sx Wannabe
Posts: 144
Joined: Mon Apr 17, 2006 6:01 pm

Post by niceguy » Mon Mar 11, 2013 11:54 am

I know on my NA '93 Altima, the mesh provides a laminar airflow that helps keep the MAF/readings happy.

I've run a 'hybrid' intake on the car for years with a KN cone filter bolted to a maf adaptor inside the airbox (to reduce heatsoak) but it required removing the mesh.

I finally ditched that setup late last year after finally realizing that it was causing my idle to fluctuate noticeably and car was going rich (after ruling out everything else over a few months and many gallons of unburned gas lol)

That's all I can say since I'm not FI currently....

Post Reply