Fuel pump wiring is mangled, help needed

Discussion on Turbo electronics including Boost Controller, Turbo Timers, WideBands, etc

Fuel pump wiring is mangled, help needed

Postby ClappedSilvia » Mon May 20, 2019 5:34 pm

Hey guys, just picked up a 1991 Nissan Silvia that had recently got a s13 dual cam KA24de swapped into it. I’ve been working on getting it running and noticed something pretty messed up, there’s a black and yellow wire coming from the EGI relay twisted to a random white wire. That white wire then runs through the car to the rear deck, which has the two speakers on it under the rear window. The wire is twisted in with a black and yellow wire connected to a plug where the speaker would sit . When this wire is disconnected my fuel pump doesn’t work. I assume that they just grabbed any 12v power that’s on when the key is turned on to power this relay. What I can’t find online is which wire should be coming from this relay feeding power to the fuel pump. Since the wiring schematics seem different for the Silvia rather than the 240sx.

Pictures will be posted of this mess below . If anyone can give me some insight on which wire I should be looking for thag would be the correct one to bring to this relay that would be awesome . Thanks .

TLDR: Egi relay has incorrect wire in pin 5 feeding it 12v. Which colour wire should be there and where should it go.
ClappedSilvia
NooB
 
Posts: 1
Joined: Mon May 20, 2019 5:21 pm

Return to Electronics

Who is online

Users browsing this forum: No registered users and 19 guests

cron