Wild afr fluctuations at WOT

Discussion about ECU Tuning Products and Theories
Post Reply
Boosted90Hardbody
NooB
Posts: 6
Joined: Sun Sep 15, 2019 4:10 pm
Location: St. George, UT

Wild afr fluctuations at WOT

Post by Boosted90Hardbody » Wed Feb 10, 2021 9:55 pm

Over the last 2 years I've been fighting an uphill battle trying to maintain a stable afr at wot. I've read every post on every forum on the subject, or related subjects, but the (not quite) infinite knowledge of the internet has not rendered a solution. I've replaced my wideband gauge and sensor three times now, adjusted every setting in TS, checked high speed tooth/trigger loggers, checked every single damn ground, rewired everything I could think of that might help, nothing has made a noticeable change. Figured it's about time to start a thread to try and get some help. Here's my setup:

1990 nissan d21
Sohc ka24e
8:1 wiseco pistons
Eagle rods
Mspnp2 ecu running sequential injection
Deatschwerks 800cc injectors
O&j stage 1 hydro cam
Pioneer valve springs
Martin industries adjustable cam gear, 6 deg advance
Wahlbro fuel pump(not sure which one, boss gave it to me)
China special t3/t4 5456 .63 ar turbo
Aem 30-4110 wideband sensor
Hks ssqv bov

Things I've ruled out:
Injector latency
Coil dwell( unless it's supposed to be over 5.5ms, didn't test any higher than that)
Oil contamination in intake through pcv( had some, none since new catch installed)
Fuel pressure seems steady(3.5 bar at idle 1:1 rising rate fpr)
Duty cycle and pulse with are steady, max 65% duty at 20psi boost
Fuel and spark tables are smooth af
Signal from cas is clean af
Injector timing(could be a factor at such low duty cycle, I've tried changing quite a bit, no improvement)
I have developed a slight exhaust leak pre turbo, afr from previous data logs show the same fluctuations, I doubt this is the problem.

Here's a snap of a run I did on the dyno last weekend
20210210_212154.jpg
I'm straight out of ideas, has anyone ever seen afr fluctuations like this?

User avatar
R34SR
Belongs To The TOP CONTRIBUTING MEMBERS!
Posts: 1925
Joined: Thu Sep 25, 2008 6:09 pm
Location: Florida

Re: Wild afr fluctuations at WOT

Post by R34SR » Thu Feb 18, 2021 10:51 pm

So the sensor responsible for measuring the AFR content of your exhaust gas is fluctuating.....but you have ruled out the exhaust gas leak pre turbo/pre afr sensor as the culprit....


Where is Tiny T when I need him....

Anyways let me not be "that guy" that turns this place into zilvia.net.....please fix your exhaust leak.
MEGASQUIRT 2 PNP
AEM IGN1A COILS
EAGLE-ARP-SUPERTECH 9:1 KA24DE
BW S257 SX-E .78AR
ID1050x Injectors
Full Race twin scroll manifold
ISIS FMIC
Mazworx z32 tranny swap
CTS V CALIPERS
STANCE LX+ Coilovers
J30 LSD
AME FS01 WHEELS 18X9 +25



TinyT wrote:for the love of god, post your setup, do you really think you can get an answer after saying HI ME CAR HAS TURBO NOW BUT I CANT BWAAA PSHH WITH IT WHATS WRONG

Post Reply