Omar's S13

This is for all those PICTURE THREADS ONLY. Motor installs, product writeups, showing off your car, put the thread in here.
Post Reply
0m3r
Driving Mom's Station Wagon
Posts: 38
Joined: Fri Dec 04, 2009 5:48 pm

Omar's S13

Post by 0m3r » Thu Apr 10, 2014 6:08 pm

Hey Guys, I have been on Ka-t.org for a while but never made a thread for my car. So here it goes. I bought my car in 2009, it looked like this, besides the window tints and fog lights Image

After driving N/A for about a year I decided to go turbo, It was my first 240 had no idea about the engine, so I had a mechanic rebuild it for me, BIG mistake. The guy didn't know what he was doing, got the car out of his garage, it was shooting fireballs out the exhaust, and bogged like hell :angry-teeth: . Took it to another shop, they found out it had 7 vacuum leaks, and the timing was way off , also one fuel injector was not working :( . All in all spent $700 on trying to get the car running . After driving for a few months the car started messing up again it would lose power while driving, couldn't figure it out because it would do it whenever it felt like. One day it just quit running, It wouldn't hold idle, so I parked it and started driving my other car. I bought some new parts and decided to work on the car myself. After doing some research I found I had no intake manifold gasket between the top and bottom runner so It was causing a huge vacuum leak. I fixed that and decided to go turbo on stock internals.
Image

This^ was my setup for about 6 months till I blew the rings on the 3rd cylinder after my wastegate line popped off. Here is a picture of the damage Image
It ran great with only 5psi from a t3.
Another pic from inside, the oil pressure and egt temp gauges were not connected.
Image

And another one from outside
Image

Here's a video I made just doing a small pull
https://www.youtube.com/watch?v=KzJbP3w ... XAjTM7lldQ


Since last fall I have rebuilt the engine and went bottom mount running a gt2871r at 8psi, same fuel setup sr370cc. Currently I'm having problems with it running rich, with my check engine light solid. I'm pretty sure its something to do with my ecu. Anyway here are some current pics of the car
Image

J30 Brakes
Image

Cp pistons with stock rods
Image

Image

Image

Image

and here is something for a future build
Image

That's all for now. Thanks for stopping by.

niceguy
240sx Wannabe
Posts: 144
Joined: Mon Apr 17, 2006 6:01 pm

Re: Omar's S13

Post by niceguy » Fri Apr 11, 2014 5:35 pm

Hey nice job so far. At least you're learning how to do things on your own although it's really sad how paid mechanics sometimes have no problem getting paid for doing garbage work....5psi is definitely enough to have some fun, or was lol. Keep up the good work!

0m3r
Driving Mom's Station Wagon
Posts: 38
Joined: Fri Dec 04, 2009 5:48 pm

Re: Omar's S13

Post by 0m3r » Fri Apr 11, 2014 9:35 pm

^ thanks man.

mewantkouki
Knows Some Stuff About 240's!
Posts: 268
Joined: Sun Dec 09, 2007 5:46 pm
Location: Orlando, Fl
Contact:

Re: Omar's S13

Post by mewantkouki » Sat Apr 12, 2014 7:02 am

Buy larger injectors...

User avatar
shift_down
SuperMod
Posts: 1833
Joined: Mon Nov 28, 2011 11:00 am
Location: tulsa oklahoma

Re: Omar's S13

Post by shift_down » Sat Apr 12, 2014 4:47 pm

mewantkouki wrote:Buy larger injectors...
Yes!
Get 1600cc injectors :)

You will want to run e85, especially since you have forged pistons. Otherwise you will just keep buying new injectors. We've all been through this.
Come at me bro

Fast
Reliable
Cheap;
You can only pick two, so choose wisely!

My build thread: viewtopic.php?t=57539

0m3r
Driving Mom's Station Wagon
Posts: 38
Joined: Fri Dec 04, 2009 5:48 pm

Re: Omar's S13

Post by 0m3r » Sun Apr 13, 2014 12:08 pm

why would i need bigger injectors, and why would i need to run e85 my goal is just 300hp daily driver.

TrackStarGT
Knows Some Stuff About 240's!
Posts: 363
Joined: Sat Nov 02, 2013 5:00 pm

Re: Omar's S13

Post by TrackStarGT » Sun Apr 13, 2014 12:38 pm

I was thinking the same thing, I dont know what prompted those suggestions, i read over the whole thread twice trying to figure out why you would need 1600cc injectors and e85. lol
Daily Driver: 2010 Toyota Tundra CrewMax 5.7 TRD
Project and DD: 1995 Nissan 240sx Frankenstein

I live and breathe physics, mechanics, motorsports!!

My build thread viewtopic.php?f=40&t=60602

User avatar
shift_down
SuperMod
Posts: 1833
Joined: Mon Nov 28, 2011 11:00 am
Location: tulsa oklahoma

Re: Omar's S13

Post by shift_down » Sun Apr 13, 2014 3:33 pm

370ccs are not good at all for 300hp, you will max out your injectors and risk going lean and blowing up your motor. At least get some 1000cc. If you run e85 on 1000cc injectors with your setup, you will get around 350-400 without any worries of detonation. E85 is almost impossible to detonate with if you tune it. If you dont have e85 around your area, then just go with 740cc injectors and do your thing with those.
Come at me bro

Fast
Reliable
Cheap;
You can only pick two, so choose wisely!

My build thread: viewtopic.php?t=57539

0m3r
Driving Mom's Station Wagon
Posts: 38
Joined: Fri Dec 04, 2009 5:48 pm

Re: Omar's S13

Post by 0m3r » Sun Apr 13, 2014 4:43 pm

We'll i know 370cc will max out around 250-260. I was gonna switch to 550cc in the future. Is 400 achievable with my setup? Because if it is i work next to a gas station that sells e85, so that's not a problem. Also to run e85 will I need to replace any fuel lines?

User avatar
S14wayz
Knows Some Stuff About 240's!
Posts: 419
Joined: Wed Apr 24, 2013 11:11 am
Location: BC, Canada

Re: Omar's S13

Post by S14wayz » Sun Apr 13, 2014 7:33 pm

fuel lines are fine just need e85 compatible fuel pump which most of the aftermarket ones are
Image
My S14 Build Thread
viewtopic.php?f=40&t=59534

0m3r
Driving Mom's Station Wagon
Posts: 38
Joined: Fri Dec 04, 2009 5:48 pm

Re: Omar's S13

Post by 0m3r » Mon Apr 14, 2014 12:01 am

I have a walbro 255 that should work right

User avatar
S14wayz
Knows Some Stuff About 240's!
Posts: 419
Joined: Wed Apr 24, 2013 11:11 am
Location: BC, Canada

Re: Omar's S13

Post by S14wayz » Mon Apr 14, 2014 8:48 am

Yeah thats perfect
Image
My S14 Build Thread
viewtopic.php?f=40&t=59534

User avatar
superDorifto
Dont Question My Nissan Knowledge
Posts: 508
Joined: Tue Oct 11, 2005 6:58 pm

Re: Omar's S13

Post by superDorifto » Wed Apr 16, 2014 2:05 pm

shift_down wrote:370ccs are not good at all for 300hp, you will max out your injectors and risk going lean and blowing up your motor. At least get some 1000cc. If you run e85 on 1000cc injectors with your setup, you will get around 350-400 without any worries of detonation. E85 is almost impossible to detonate with if you tune it. If you dont have e85 around your area, then just go with 740cc injectors and do your thing with those.
Your heart is in the right place, but 1000cc injectors are way overkill for his level of build/tune, even the 740s are in my opinion way too big.

370s start reaching max duty cycle (above 85%) between 260-290 whp depending on tune, weather conditions, and the specific turbo set up.

550ccs are pretty much the perfect size for 300 whp and comfortably staying under 85% duty cycle on a KA....its what I have in my own build and is pretty much tried and true.

I dont have much experience with E85 as we do not have it locally, but I understand that you def need bigger injectors when you're running corn.

0m3r
Driving Mom's Station Wagon
Posts: 38
Joined: Fri Dec 04, 2009 5:48 pm

Re: Omar's S13

Post by 0m3r » Fri Apr 18, 2014 8:45 pm

Well my car was running super rich I had tried everything. Today I changed the ecu and went back to stock injectors, guess what It starts right up and idles great. Turns out my ecu was bad nowI'm gonna break the engine in NA, the setup will stay the same I'm just gonna run a separate pipe from the throttle body straight to the maf. I'm going to switch to a Aem stand alone, 1000cc injectors and E85. I just have to sell some parts though before I can do all that.

0m3r
Driving Mom's Station Wagon
Posts: 38
Joined: Fri Dec 04, 2009 5:48 pm

Re: Omar's S13

Post by 0m3r » Mon Jun 09, 2014 9:34 pm

Well I finally got my car running the way I want. I didnt have enough funds for a stand alone ecu and e85 so I just settled for 550cc and enthalpy with z32, just a typical setup. Currently pushing 10psi. I added a video :mrgreen:
http://www.youtube.com/watch?v=8pQYXrVofSU

User avatar
S14wayz
Knows Some Stuff About 240's!
Posts: 419
Joined: Wed Apr 24, 2013 11:11 am
Location: BC, Canada

Re: Omar's S13

Post by S14wayz » Thu Jun 26, 2014 2:57 pm

Nice man, did you dyno it yet?
Image
My S14 Build Thread
viewtopic.php?f=40&t=59534

Post Reply