Adam's formerly supercharged... now soon-to-be-turbo'd, S14

This is for all those PICTURE THREADS ONLY. Motor installs, product writeups, showing off your car, put the thread in here.

Adam's formerly supercharged... now soon-to-be-turbo'd, S14

Postby adamky » Fri Oct 21, 2011 5:42 pm

*** For latest updates, see: Part 3: Adam's fantastic voyage from supercharged to turbocharged*** 8)


1/29/17 EDIT: This is the current mod list.
Engine:
Wiseco 9:1 .5mm over
Eagle rods
ARP rod bolts and main studs
11mm ARP CA625+ head studs installed w/ time serts from www.MechanicsToolsAndBits.Com
Stock head with BC valve springs
JWT S1 cams
JWT cam gears (settings can be found here)
Greaser's mechanically locked timing chain tensioners
Xcessive manufacturing oil pan adapter (modified by removing the rear trans flange, which normally prevents access to the rear oil pan bolts)
ISR Cast Aluminum sump with custom-made, counter-weighted trap door setup
3/8" thick oil pickup spacer (lowers the pickup-to-pan-clearance from ~3/4" to a more industry-standard ~3/8"
Skullwerks Oil block

Turbo setup:
Custom equal-length exhaust manifold
PT5857 - dual ceramic ball-bearing, 4" ported S-cover, T3-flanged .63 A/R turbine (4-bolt)
3" downpipe
RSR ExMag 80mm exhaust (with 2 additional straight-through resonators)
Precision 46mm wastegate (re-circulated)
Xcessive intake manifold
Q45 throttle body
Treadstone Performance TR1035 Intercooler
3" intercooler piping
Tial 50mm BOV

Fuel Setup:
Walbro 450/485 E85-compatible pump
Power House Racing billet fuel hat
-8 AN PTFE feed line, -6 AN return
Xcessive fuel rail drilled and tapped for 3/8 NPT to -8 AN adapters
Fore Innovations F1i Fuel Pressure Regulator
Fore Innovations 88mm Inline Fuel Filter
Bosch high-imp 1600cc injectors

ECU/Electronics:
Nistune S13 OBD1 KA24DE ECU (w/ Feature Pack)
S13-S14 conversion harness
Z32 MAF in aluminum housing (blow-through)
Zeitronix ECA-2
TurboSmart E-boost Street EBC
4-port boost solenoid
Stock S14 ignition w/ Kenne Bell Boost-a-Spark
Magnecor 8.5mm plug wires
NGK BKR7EIX

Drivetrain:
Mazworx Z32-KA trans adapter kit
Z32 trans
Xcessive Z32 short shifter kit (heavily modified to add rididity)
Z1 Motorsports shifter (the one from Mazworx sucks)
RB25 OEM-style steel flywheel
ACT 350Z NZ1-XTSS - XT/Perf Street Sprung
S15 HLSD

Extras/etc:
Greaser's patented PCV vacuum tank setup w/ 7 gal air tank in-trunk
-8AN PTFE hose for tank-to-intake manifold line
-6AN PTFE hose for tank-to-crankcase line

Suspension:
Ground Control full coil-overs w/Koni struts (aligned and corner-balanced)
SPL RUCA
SPL Front tension rods
Energy Suspension subframe and diff bushings

Wheels/Tires:
OEM 350Z base wheels (17x7.5F, 17x8R)
225/45ZR17 Front 245/40ZR BFG G-Force Sport COMP-2


-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------



So last year, I supercharged my stock KA and had a blast with the stock motor and an AEM water meth kit: viewtopic.php?t=49060

However, earlier this year I had a problem with my water injection system, which was my own fault. I was cleaning the filter/screen in the nozzle, and when I screwed the two halves of the nozzle together, I apparently didn’t get them tight enough. The AEM nozzle uses a nylon washer to create the seal between the two halves of the nozzle, and if you don’t get them tight enough, most of the water meth sprays out the side of the nozzle, rather than into the intake pipe. After one quick full boost run, I knew I had broken ringlands when I took off at the next light.

Sure enough, a quick check of the intake piping and I could see everything was coated in oil (my PCV was re-circulated back into my intake at the time). Pulled the motor and tore it down to see I had 3 of 4 pistons with broken ringlands. KA-BOOM!

Image
Image
Image
Image
Image

I had a spare motor in the garage, but decided to go ahead and build the bottom end and get the head decked and prepped for a Cometic. I dropped it off at Bell Motors in Louisville, KY to have the machine work done and bottom end assembled.
Last edited by adamky on Fri Sep 11, 2015 12:12 am, edited 5 times in total.
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Postby adamky » Fri Oct 21, 2011 5:43 pm

In the meantime, I pulled out my old AEM water injection system, and installed a Snow Performance MAF-based system with 2.5 gal tank. Image

Next to the old AEM pump and tank:
Image

Fabbing a mount for the tank to be mounted over the pump:
Image
Image
Image
Image

Mounted in the trunk:
Image
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Postby adamky » Fri Oct 21, 2011 5:45 pm

Because the AEM controller was mounted in my dash panel where the HVAC had been, and I sold the AEM kit, I had to make a new panel to mount the water injection and boost control switches, and a couple of gauges. I used a couple of pieces of smoked plexi, a Dremel, and some plastic epoxy called plastic weld. Took a while to make but it turned out good.

For comparison, here's the old panel which I hated from day 1. Looks like poop, and I'm glad it's in the scrap bin where it belongs. (click for full size)
ImageImageImage


Here is the new panel. The gauges are for oil pressure, and air intake temps. With no intercooler, I have always wondered just how hot the air is going into the engine, so that’s why I got the AIT gauge.
Image
Image
Image

VIDEO
Image


Controller mounted in the glove box:
Image

Repainted the engine bay:
Image
Image

Star Specs 245/40 R and 225/45 F
Image
Last edited by adamky on Mon Sep 07, 2015 9:32 pm, edited 11 times in total.
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Postby adamky » Fri Oct 21, 2011 5:55 pm

After over 2 months, I finally got the motor back. Specs are:
-Wiseco 9:1 pistons .020” over
-Eagle H-beam rods
-Clevite Bearings
-ARP rod and main studs
-ARP 10mm Head studs
-Cometic MLS HG
-All new OEM timing parts, oil pump, oil pan
-Block was cleaned, hot tanked, bored .020” over, crank bore was line honed, deck resurfaced to <50 RA for Cometic MLS HG, rotating assembly balanced, and they assembled the bottom end
-Head is my factory 140,000 mile head with JWT S1 cams and cam gears (properly re-shimmed). They did resurface it to (<50 RA) along with both front covers.
Image
Image
Image
Image
Image
Image
Image
Image
Last edited by adamky on Sat Jan 14, 2012 4:15 pm, edited 1 time in total.
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Postby adamky » Fri Oct 21, 2011 6:14 pm

Future-proofing :wink:
Image
Image
Image

Cleaned and painted everything with high temp paint:
Image
Image
Image

Motor assembly time:
Image

All new OEM timing parts:
Image
Image
Image

I didn’t get a pic of the cometic. I coated it in copper spray on both sides before installing it. Torquing down the ARPs:
Image
Last edited by adamky on Fri Oct 28, 2011 8:38 pm, edited 1 time in total.
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Postby Toe » Sat Oct 22, 2011 7:00 am

What did you torque your arp head studs too?
Broken link is broken
User avatar
Toe
240sx Wannabe
 
Posts: 157
Joined: Thu Aug 24, 2006 2:50 pm

Postby adamky » Sat Oct 22, 2011 8:57 am

80 ft/lbs
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Postby adamky » Sat Oct 22, 2011 8:59 am

Cams in, checking and setting valve lash. The lash was actually already set for these cams, but while moving the head around with the cams out, 5 cam buckets fell out. So, I had to put them back in and then check the lash to figure out which ones were messed up:

Image

Finding true TDC to degree cams. I decided to take out some of the overlap from these N/A cams, advancing the exhaust cam 5 degrees, and retarding the intake 5. This should help increase power in the mid range to top end. I'm hoping this will keep the power from falling off so bad up top, but we'll see if that works out when I dyno it.
Image
Image

Skullwerks oil block. I decided to change up my PCV system, replacing the one way valve with a 5/8” hose barb which will vent to a catch can and then to atmosphere.
Image
Image
Image
Image
Image
Last edited by adamky on Wed Nov 02, 2011 6:44 pm, edited 4 times in total.
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Postby superDorifto » Sat Oct 22, 2011 10:48 am

MOAR!!!!!!!!! :evil:

Except for a few small details our builds are going to be very similar. Also the closedt E85 to me is in NY....
User avatar
superDorifto
Dont Question My Nissan Knowledge
 
Posts: 504
Joined: Tue Oct 11, 2005 6:58 pm

Postby NeverSatisfied » Sat Oct 22, 2011 11:36 am

Nice build.
If its worth doing, its worth overdoing.
User avatar
NeverSatisfied
Knows Some Stuff About 240's!
 
Posts: 223
Joined: Thu Sep 15, 2011 10:23 am
Location: Arizona

Postby sus@n » Sat Oct 22, 2011 4:05 pm

Very nice man! !
sus@n
NooB
 
Posts: 3
Joined: Mon Oct 17, 2011 2:43 pm
Location: GA

Postby adamky » Sat Oct 22, 2011 6:42 pm

Thanks.

With the supercharger unbolted from the supercharger plate, I realized that the coating was coming off of my rotors. Everyone I talked to advised me to just take the coating off, rather than get pieces of it sucked into my freshly built motor. Of course, you lose a little efficiency this way, but I can always swap in a smaller pulley. I disassembled it and used aircraft stripper to take the rest of the coating off.
Image
Image
Image
Image

The Mobil1 grease is for the needle bearings in the back of the supercharger housing. The oil and housing sealant are from a Magnuson supercharger coupler replacement kit.
Image
Image
Image
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Postby adamky » Sat Oct 22, 2011 6:42 pm

I decide to add a direct port setup from Devils Own to the Snow performance water injection system. This is simply to ensure even flow to each cylinder. The “plenum” within the supercharger isn’t very large, and with only one nozzle mounted pre-supercharger, I was always worried I was getting uneven flow to each cylinder, especially at higher boost levels. I’m using 5, 50 ml/min nozzles. One for each intake runner and one at the supercharger inlet to give a little cooling and sealing effect on the rotors:

***EDIT: I have since removed the direct port setup and switched back to one nozzle (175ml/min) pre-supercharger. This is due to the decision to switch to E85 and use the nozzle pre-supercharger to generate 1-2 psi extra boost***

Image
Image
Image
Image

Testing the setup:
Image

Bolting the intake manifold and supercharger back together:
Image
Image
Image
Last edited by adamky on Fri Nov 18, 2011 9:27 pm, edited 5 times in total.
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Postby adamky » Sat Oct 22, 2011 6:45 pm

Motor going back in. It was a PITA doing it with this 1 ton hoist. It just wasn’t long enough. At the time I needed one, it was literally the only one I could find in town. This was the only one Harbor Freight had in stock.
Image
Image


Taurus fan is out, Altima dual fans are in:
Image

New Coolant overflow to replace my ugly yellow plastic stock one:
Image
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Postby supakat » Sat Oct 22, 2011 11:56 pm

Nice. How are the dual altimas running? I am running Taurus and works fine.
12.96 @ 116.36 - 2.1 60ft - 11/2011
13.1 @ 114 - 2.3 60ft - 8/2012
KA24DE-T
Image
Build thread/Blog
YouTube Channel
User avatar
supakat
SuperMod
 
Posts: 8014
Joined: Sun Oct 08, 2006 12:13 pm
Location: FL

Postby street_240sx » Sun Oct 23, 2011 3:07 am

altima fans FTW!!!!!!! i cant wait til i can run water meth i just need to figure out where i want the nozzle. i do like the idea of direct port tho
03 evo8 gsr: stroker 2.3 ;)

04 evo8 gsr: totalled

96 integra gsr: sold

89 s13 coupe: stock dohc, gt3076, megasquirt

started 3/15/08, running 1/18/09, finally turbo 2/9/14 lmfao
User avatar
street_240sx
Belongs To The TOP CONTRIBUTING MEMBERS!
 
Posts: 1919
Joined: Sun Feb 10, 2008 7:31 pm
Location: 520 AZ

Postby adamky » Sun Oct 23, 2011 4:37 pm

superDorifto wrote:MOAR!!!!!!!!! :evil:

Except for a few small details our builds are going to be very similar. Also the closedt E85 to me is in NY....


Thanks. Are you still planning to run the custom charge cooler? E85 has gotten fairly common around here, so I'm gong for it. I have at least 5 stations within a 6-7 miles radius that have it. I've been running my GMC Sonoma on it for a while because it gives it a nice little power increase. It's a complete slug on 87 octane...runs much stronger on corn.

supakat wrote:Nice. How are the dual altimas running? I am running Taurus and works fine.


They are running fine. I liked my Taurus fan, but it was making noises and on its way out. The altima fans are great because the are slim. They look nicer, IMO.

street_240sx wrote:altima fans FTW!!!!!!! i cant wait til i can run water meth i just need to figure out where i want the nozzle. i do like the idea of direct port tho


Awesome, good luck with it. The direct port setup ran great. Never had an issue with it for the month or so I ran it. I now just have one nozzle pre-supercharger, which I like because I get an extra 1-2 psi of boost. I'm seeing 15 psi now. :twisted:
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Postby adamky » Sun Oct 23, 2011 4:42 pm

The header was looking rough, so I decided to try out some VHT FlameProof High temp paint. In my experience, most high temp header paint lasts a few hundred miles at best before it all burns off. This stuff if supposed to stand up to more abuse and last longer than your average high temp paint, so we’ll see. It looks and feels exactly like ceramic coating. I’ve got 500 miles on it so far, and it still looks just like this.
Image
Image
Image
Image
Image

Catch can for PCV:
Image
Image
Image


Last time, my exhaust was extremely loud, so I bought 2 straight through resonators in the hopes of quieting it down some. The resonators made a big difference in the noise level. It’s still fairly loud in high boost, but I can actually hear supercharger whine now.
Image
Image
Image
Image
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Postby adamky » Sun Oct 23, 2011 4:46 pm

Everything bolted back together and ready to start break in. I’m using the motoman break-in method. Google it if you don’t know what that is:
Image Image Image
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Postby blacks13coupe » Sun Oct 23, 2011 6:53 pm

Bad. Ass.
Image
blacks13coupe
Dont Question My Nissan Knowledge
 
Posts: 561
Joined: Fri Oct 10, 2008 10:06 am
Location: Fort Worth TX

Postby supakat » Sun Oct 23, 2011 6:56 pm

I would eat my dinner off that bay!
12.96 @ 116.36 - 2.1 60ft - 11/2011
13.1 @ 114 - 2.3 60ft - 8/2012
KA24DE-T
Image
Build thread/Blog
YouTube Channel
User avatar
supakat
SuperMod
 
Posts: 8014
Joined: Sun Oct 08, 2006 12:13 pm
Location: FL

Postby adamky » Sun Oct 23, 2011 7:12 pm

Thanks! I feel like I've been working on this thing non stop for years now!

I decided to replace my 5 yr old AGX And Eibach Sportline suspension with something a little better. This is the Ground Control complete kit for S14s with Koni 8610 fronts, Koni 8040 rears, GC camber plates, GC coilover with Eibach springs (425 lb/in front, 325 lb/in rear), and GC custom front strut housings for more wheel clearance. Image
Image
Image

Old suspension:
Image
Image

New vs old.
Image
Image
Last edited by adamky on Fri Oct 28, 2011 8:07 pm, edited 1 time in total.
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Postby street_240sx » Sun Oct 23, 2011 9:25 pm

Koni ftw!!!!!!!!
03 evo8 gsr: stroker 2.3 ;)

04 evo8 gsr: totalled

96 integra gsr: sold

89 s13 coupe: stock dohc, gt3076, megasquirt

started 3/15/08, running 1/18/09, finally turbo 2/9/14 lmfao
User avatar
street_240sx
Belongs To The TOP CONTRIBUTING MEMBERS!
 
Posts: 1919
Joined: Sun Feb 10, 2008 7:31 pm
Location: 520 AZ

Postby adamky » Fri Oct 28, 2011 7:34 pm

Rust repair time. Horray :roll:
Image

Image

Image

Image

Image

Image

Image


I hit it with spot welds about every 1/2inch, and then hit it with body sealant
I know my welding sucks. I think it will get the job done though.

Image


Finished it off with rubberized undercoating:

Image
Last edited by adamky on Fri Oct 28, 2011 7:40 pm, edited 1 time in total.
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Postby adamky » Fri Oct 28, 2011 7:39 pm

More rust repair:

Image

Image

Image

Image
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Postby adamky » Fri Oct 28, 2011 7:43 pm

Rust repair complete, time for suspension install:

Image

Image

Image

Image


Image

Image
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Postby adamky » Fri Oct 28, 2011 8:25 pm

The only bad part about the suspension is that the springs they included are really not tall enough. With the suspension raised all the way up, I was dragging my header over every speed bump, and I was hitting the front bump stops over any decent sized bump. Especially when cornering hard.

I contacted Ground control, and after sending them some pics of the setup and explaining the situation, I was able to get them to send me springs with very similar rates , but 1" taller. I went from 5" tall, 425 lb/in front, 7" 325 lb/in rear, to 6" 440 lb/in front and 8" 330 lb/in rear.

I didn't get a comparison pic of the rears, but here are the front springs new vs. old:

Image

Image



I was able to raise it up abouth 1/2 inch. I am no longer scraping over speed bumps or bottoming out, and the car really handles great. It just feels so controlled and smooth. Rides much smoother than my old setup.
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Postby driftfiend » Fri Oct 28, 2011 10:35 pm

very nice build bro
driftfiend
Dreams of owning a 240!
 
Posts: 51
Joined: Wed Apr 09, 2008 7:17 am
Location: jerzy

Postby redpotatoes » Sat Oct 29, 2011 6:53 am

Nice build !

I have a question for you about the air temp gauge/sensor your using. Where did you put the sensor, on the intake manifold, throttle body, etc ? Which one did you use (OEM S14) ? Is it only displayed on your gauge or you managed to log it ? I want to have a air temp sensor to monitor the water injection effects but also want to have the ability to log it.
User avatar
redpotatoes
Dont Question My Nissan Knowledge
 
Posts: 823
Joined: Thu Jun 09, 2005 6:19 am
Location: Qc

Postby adamky » Sat Oct 29, 2011 12:15 pm

Thanks.

The intake temp sensor is just the gauge and sensor from PLX. I cannot log it. The sensor is located in the top of the supercharger plate. You can see it in the engine pics if you look close. It's the silver wire coming from between runners 1 & 2.

I did glance at it a little today while tuning. During a run with water meth, I'm seeing 30-40 degree drops in temperature. And they stay lower for a short time after the run.
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, etc, etc...
--> YouTube channel --> my build thread
Image
adamky
SuperMod
 
Posts: 3502
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Next

Return to KA-T Picture Threads

Who is online

Users browsing this forum: No registered users and 61 guests

cron