Injectors Not Spraying, No Start

Basic tech questions such as future setups, different turbo kits, car diagnosis, etc

Injectors Not Spraying, No Start

Postby 240Life » Sun Mar 18, 2018 7:05 pm

Hi all, just looking for potential of what to check next. Have a ka-t with about 6k on it. Just last week I washed it and pulled it back in the garage. The next morning tried to start and just cranked. Upon investigation i have spark, fuel pressure at regulator, 12v at injectors, code 55 all good on ecu. No fuel in the cylinders. Car is s13. Any advice on where to go from here would be great I’m going to try and get some noid lights tomorrow as an ecu check.

Update - I checked with the noid lights and they’re getting signal from ecu. I unplugged 2 and 4 and it tried to running rough. That leads me to believe those wires aren’t giving enough juice to the injectors, a short somewhere great..
240Life
Driving Mom's Station Wagon
 
Posts: 35
Joined: Fri Nov 06, 2015 2:52 pm
Location: GA

Re: Injectors Not Spraying, No Start

Postby unicoder » Sun Apr 01, 2018 2:43 pm

if you are getting response on the noid lights, and are sure you are getting spark and air...

Check your engine grounds! Make sure they are solid! Hell make a new one and take it from the intake mani to the firewall, or get creative.

Also if you jerry rigged your battery cables, fix that mess. You may have a way simple fix on your hands
unicoder
NooB
 
Posts: 6
Joined: Sun Apr 16, 2017 11:51 am

Re: Injectors Not Spraying, No Start

Postby p00t » Thu Jul 12, 2018 9:12 pm

Determine which side is not getting the "juice" flowing

Take off one of the injector connectors and find the + terminal with a multimeter. Jumper battery + to that terminal. If the car tries starting better with the three injectors and extra power fed to them then you problem is in the wiring from the battery/fuse box to the injectors. If there is no change its a ground issue likely with the ECU (which grounds the injectors to turn them on).
KA24DETT still alive
Image
User avatar
p00t
Encyclopedia-Nissan
 
Posts: 1070
Joined: Sun Aug 28, 2005 10:27 pm
Location: West of Detroit


Return to KA-T Tech. Basic

Who is online

Users browsing this forum: Google [Bot] and 71 guests

cron