KA-T build stuck

Basic tech questions such as future setups, different turbo kits, car diagnosis, etc
Post Reply
Kaashin
NooB
Posts: 1
Joined: Mon Jul 13, 2020 10:50 pm

KA-T build stuck

Post by Kaashin »

It's been a long time since I was on this forums looking up resources to source parts. Got everything, then life happened and 7 years the project went nowhere. Had kids, no time to play, and forgot mostly everything. Last year with a help of a friend, finally got the parts all put in and now stuck on the hardest 10%. Parts are all in, car runs, now I need to figure out tuning, but before I can get to that I'm getting some odd AFR readings. When idle my meter seems to hit the meters max at 21.8, but when I got on throttle it'll fluctuate everywhere but mostly give me readings bouncing between 7-10. Not really running much boost right now because things seem out of sorts.

Was wondering if anyone could provide some tips on what I need to look at next to diagnose this? I'm pretty basic at this, pretty much fell out of the loop of everything and just looking for some help.

If anyone has suggestions on suggested EMS for tuning now too that'd help too. Nistune still in business? Currently just have a enthalpy tune but plan to replace it with something proper. Just dish for a AEM EMS?

Parts
GT2871R
Walbro 255lph
Innovate LC-1 Wideband
Deatschwerks 550cc Injectors
Greddy FMIC
Z32 MAF
modulation
240sx Wannabe
Posts: 107
Joined: Fri Jun 12, 2015 4:55 pm

Re: KA-T build stuck

Post by modulation »

Have you tried to re-calibrate the wideband?
LC-1 was really sensitive to grounding too, so double check it's tight and not connected near another voltage gnd (like radio etc..)
Problem sounds electrical to me unless it bogs, smells super rich and almost doesn't run. If it seemingly runs good with 7-10:1 afr with no black smoke or smelling super rich I'd bet double check how you hooked up the lc1 and recalibrate it.
Bigcam
Learners Permit
Posts: 10
Joined: Wed Mar 23, 2016 3:09 am
Location: Australia

Re: KA-T build stuck

Post by Bigcam »

check for exhaust leaks before the sensor, even a very small leak can cause errors/flucuations in the readings.
Bigcam
Learners Permit
Posts: 10
Joined: Wed Mar 23, 2016 3:09 am
Location: Australia

Re: KA-T build stuck

Post by Bigcam »

Have a look at Megasquirt MS3X for a stand alone EMS.
User avatar
DRFTPUNK
Knows Some Stuff About 240's!
Posts: 314
Joined: Sun Feb 07, 2010 10:03 pm
Location: Port St Lucie FL

Re: KA-T build stuck

Post by DRFTPUNK »

X2 on exhaust leaks, I thought I was good but it turned out my cheap ebay wastegate was leaking bad. I took it out, took it apart, re-lapped/seated the valve and tightened down components and now my AFRs are almost perfect. I am running open dump so I'm wondering how/ if that is affecting readings
supakat wrote:I will tell you one thing, if I had to choose between stretched tires and stretched pu$$y, I would go with tires.

S14 Zenki, GT35, 80lb injectors, RS Enthalpy tune, Eagle/ Wiseco 8.8/1.
Formerly Known as ISpentAllMyMoneyOnTires

RIP 480sx
Post Reply