1993 coupe 96kmiles back from the dead

This is for all those PICTURE THREADS ONLY. Motor installs, product writeups, showing off your car, put the thread in here.
Post Reply
Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

1993 coupe 96kmiles back from the dead

Post by Here4Knowledge » Wed Aug 10, 2016 3:10 am

Whatsup everyone! This is my first forum to ever join, and I thought. What better place than Ka-T! The plan is to eventually get a snail on her..Hehe..much longer down the line of investments. Suspension, brakes, and Driveline first! Anyhow, Let's get To business. I'm a 17yr old Senior and I just bought my first car. She's a 1993 bonestock Coupe. No rust! *edit found some underneath the battery ,near the windshield reserve tank..? 96kmiles. Auto. Original owner. Power windows and power mirrors that work! Interior is spotless. It looks brand new! No cracks on the dash and the driver seat looks as if it's been replaced! (It's that nice! Haha) *edit I've been informed the seats that are In her are from an s14. she even comes with the HUD and electronic dash.
Last edited by Here4Knowledge on Mon Aug 15, 2016 12:30 pm, edited 1 time in total.

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 86k bonestock

Post by Here4Knowledge » Wed Aug 10, 2016 3:14 am

Now for a minor letdown. In 2006 it had been in a minor rear collision. The bumper beam had been pushed in. Not all to bad honestly. Rear bumper was toast. It was labeled a rebuilt salvage title. Driven by an elder lady, she put the baby in her garage for the past 10years. Never drove it again. Made an offer, and took it off her hands. From what my buddies and I could make out. The rear end is in okay condition. Aside from a missing bumper beam. She drives amazing! Took her on the highway home. The Throttle response is emacculate and she loves to rev through the powerband! No struggle at all. I was amazed. The tq put me in my seat a little. Took her to my buddies house that day and she's been in the garage ever since.

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 86k bonestock

Post by Here4Knowledge » Wed Aug 10, 2016 3:14 am

So far I have replaced the fuel filter, oil filter, air filter. Drained her. Put in 10w30 Castrol high mileage oil. Cleaned the MAF, and spark plug wires.. Put in NGK Iridium Spark plugs. Next, brake fluid and bleed. Coolant, diff and tranny fluid. Any other suggestions? I'm looking for some guidance, I like to learn and want to treat her right. Good parts, and reliability. Some plans so far. A front suspension rehaul! I have some funds left over and she needs it. Why not? Something is clicking after 3/4s of a turn on the left hand side. I think it's a busted tierod. Maybe LCA..idk yet. Cant wait to continue making more repairs and getting her sufficiently roadworthy.

adamky
SuperMod
Posts: 3511
Joined: Wed May 31, 2006 6:40 am
Location: Louisville, KY

Re: 1993 coupe 86k bonestock

Post by adamky » Wed Aug 10, 2016 10:50 am

Pics????
Wiseco/Eagle, JWT S1 cams, BC valve springs, PT5857, ID1700 injectors, SR20DET ECU w/ Nismotronic, COP conversion with LS ignition coils, etc, etc...
--> YouTube channel --> my build thread
Image

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 86k bonestock

Post by Here4Knowledge » Wed Aug 10, 2016 11:19 am

First night home.
Attachments
image.png

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 86k bonestock

Post by Here4Knowledge » Wed Aug 10, 2016 11:20 am

Right hand side rearend
Attachments
image.png

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 86k bonestock

Post by Here4Knowledge » Wed Aug 10, 2016 11:21 am

Left hand side
Attachments
image.png

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 86k bonestock

Post by Here4Knowledge » Wed Aug 10, 2016 11:22 am

Blurry rear end shot. Lights work!
Attachments
image.jpeg

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 86k bonestock

Post by Here4Knowledge » Wed Aug 10, 2016 11:24 am

Wanting to sell the Chucki front bumper for a pig nose! Pm me if you're down for a trade or interested. Aside from that, the interior and exterior are staying stock. No gaudy body kits or bs. Quality suspension and engine work. For my mad sexy machine.
Attachments
image.jpeg

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 96kmiles back from the dead

Post by Here4Knowledge » Mon Aug 15, 2016 12:39 pm

Next on the list is rotor and cap, along with NGK plug wires! Last night I was searching my local craigslist posts and found a part out, for a 92 coupe. Went over there had a great conversation with the guy and he hooked me up! I was able to swipe a pig nose front bumper and some L&R front Megan Coilovers! Along with Left lca, tension rod and tierod setup. All for $150! Everything looks to be in good condition. My original plan was to go with PBM full front setup. Eventually I'm still going to do something like it. For now, I couldn't pass the deal up! Somethings buggered and needs to be fixed. so might aswell, right?! I'll put some pics in. Take a look how far pushed back the left front wheel is.. The back of the tire is basically rubing the splash gaurd. She still runs and drives. Is indeed, able to turn. but the left wheel is not able to turn all the way left nor right..before I get her jacked up though. I'm going to get my hands on some front z32 rims and brake setup wth SS brake lines. Figured I'd get some more fun In!
Attachments
image.jpeg
Last edited by Here4Knowledge on Mon Aug 15, 2016 12:54 pm, edited 3 times in total.

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 96kmiles back from the dead

Post by Here4Knowledge » Mon Aug 15, 2016 12:42 pm

Not too shabby eh
Attachments
image.jpeg
image.jpeg
image.jpeg

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 96kmiles back from the dead

Post by Here4Knowledge » Mon Aug 15, 2016 12:46 pm

No radio. I don't even notice tho lol. Everytime I sit in her I completley forget and listen to the music of that KA! Here's a pic of my poor driver side wheel. I'm also going to post a pic of what appear to be a bent front lower support.. ( I don't know what it's called, any input on it would be appreciative.)
Attachments
image.jpeg
image.jpeg
image.jpeg

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 96kmiles back from the dead

Post by Here4Knowledge » Mon Aug 15, 2016 12:49 pm

Also have to find some power window buttons. Lil Sh*ts fell off :/ I'm on the hunt for a new battery too. I figured while I'm at it. Might aswell relocate it to the trunk.

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 96kmiles back from the dead

Post by Here4Knowledge » Mon Aug 15, 2016 12:56 pm

Here's that bent support. Left hand side
Attachments
image.jpeg

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 96kmiles back from the dead

Post by Here4Knowledge » Mon Aug 15, 2016 12:57 pm

Right there down by the bearing it's bent in basically touching. Sorry for the low quality pics y'all :/

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 96kmiles back from the dead

Post by Here4Knowledge » Mon Aug 15, 2016 12:59 pm

Better quality rearend shot
Attachments
image.jpeg

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 96kmiles back from the dead

Post by Here4Knowledge » Wed Aug 17, 2016 2:12 pm

Bent to hell. I wonder what type of trouble Granny got into... Upon dissasembly tension rod bearing is jacked. Control arm is done and tie rod is snapped. Really hope my subframe is a-ok.
Attachments
image.jpeg

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 96kmiles back from the dead

Post by Here4Knowledge » Wed Aug 17, 2016 2:13 pm

LCA is done. Bushings are pushed back. Probably bent bolt aswell....
Attachments
image.jpeg

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 96kmiles back from the dead

Post by Here4Knowledge » Wed Aug 17, 2016 2:14 pm

Tension rod bearing is jacked too..whoever could tell me what the frame the tension rod connects to would be great. That has been bent slightly in too. Headaches man.
Attachments
image.jpeg

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 96kmiles back from the dead

Post by Here4Knowledge » Wed Aug 17, 2016 2:18 pm

Upon removal of the strut tower, everything looked fine. Until I got down to the last bolt. The Nut became stripped and I than had to take 4hours with my handy dandy drill and metal bit. To drill through the bolt and get it out! This has all been quite the adventure...I guess next off I'm in the market for new bushings..for the new LCA, tension rod and tie rods..?

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 96kmiles back from the dead

Post by Here4Knowledge » Wed Aug 17, 2016 2:19 pm

Here we go!
Attachments
image.jpeg

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 96kmiles back from the dead

Post by Here4Knowledge » Wed Aug 24, 2016 3:00 pm

Going for a front power brace and some tension rods. I managed to get my hands on some Maxima Tie rods. Still debating on going with w PBM or Nismo front brace...

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 96kmiles back from the dead

Post by Here4Knowledge » Thu Sep 01, 2016 12:55 am

Lots and lots of fun to come soon. (:

mewantkouki
Knows Some Stuff About 240's!
Posts: 268
Joined: Sun Dec 09, 2007 5:46 pm
Location: Orlando, Fl
Contact:

Re: 1993 coupe 96kmiles back from the dead

Post by mewantkouki » Thu Sep 01, 2016 9:11 am

Stealth Custom Fab makes a triangular brace way nicer than the nismo one & pbm ones.

Image

Here4Knowledge
Driving Mom's Station Wagon
Posts: 25
Joined: Wed Aug 10, 2016 2:18 am

Re: 1993 coupe 96kmiles back from the dead

Post by Here4Knowledge » Sat Jan 14, 2017 10:39 am

SPL goodies. V5 outer, z33 Tein inner, SPL tension rods.
5speed swap is in progress. Fidenza, 1peice steel and whitebunny stage 2 in the world.
Attachments
image.jpeg

bluestorm
Learners Permit
Posts: 10
Joined: Sun Feb 19, 2017 1:00 pm

Re: 1993 coupe 96kmiles back from the dead

Post by bluestorm » Sun Mar 12, 2017 4:21 pm

I can't wait to see how it turns out.

Post Reply